Mettre à jour sa version de PHP

La plupart des hébergeurs proposent différentes versions de PHP que vous pouvez activez en ajoutant une ligne dans votre fichier .htaccess.  Si votre site web "tourne" sur une version PHP 5.2.x, vous devriez songer à configurer votre site pour PHP 5.3 ou, mieux, PHP 5.4.

A moins que vous n'utilisiez un code PHP qui ne serait pas compatible, il est préférable d'utiliser la dernière version de PHP car celle-ci est plus optimisée et plus sécurisée qu'une ancienne version.   Ainsi, l'évolution des versions de PHP suit, également, la résolution de failles de sécurité.   Rester avec une très ancienne version signifie que toutes les failles ayant été corrigées depuis lors sont toujours bien présentes sur votre site web ce qui le rends dès lors vulnérable.

Dans la mesure du possible, activez la dernière version PHP proposée par votre hébergeur.  Cette activation peut généralement se faire depuis votre panneau de contrôle (cpanel).  Si votre hébergeur ne le prévoit pas, voyez s'il propose une FAQ où il expliquerait comment procédez à l'upgrade de version.

Parce qu'il n'y a pas une seule manière de le faire, vous trouverez ci-dessous, pour information, les instructions à insérer dans votre fichier .htaccess.   Pour cela, utilisez l'option "1.4 Edition manuelle de votre fichier .htaccess personnel" de l'interface de aeSecure.

Chez tous les hébergeurs exceptés OVH

PHP 7.0

Activation de php 7.0 chez la majorité des hébergeurs : 

AddHandler application/x-httpd-php70 .php .php5 .php4 .php3

D'autres syntaxes possibles : 

SetEnv PHP_VER 7_0
AddHandler x-mapp-php70 .php

PHP 5.6

AddHandler application/x-httpd-php56 .php .php5 .php4 .php3

PHP 5.5

AddHandler application/x-httpd-php55 .php .php5 .php4 .php3

PHP 5.4

AddHandler application/x-httpd-php54 .php .php5 .php4 .php3

PHP 5.3

AddHandler application/x-httpd-php53 .php .php5 .php4 .php3

Chez OVH

La sélection de la version de PHP chez OVH se fait grâce à un fichier nommé .ovhconfig qu'il faut manuellement créer et placer dans le dossier racine de son site web; au même endroit que le fichier .htaccess.

Selon les versions supportées par OVH, le fichier doit contenir la ligne app.engine.version suivi du numéro de version souhaité; par exemple :

app.engine.version=5.6

Plus d'info : Configurer le PHP sur son Hébergement Web OVH


La syntaxe à ajouter à votre fichier .htaccess dépend d'un hébergeur à un autre.  Soyez certain d'utiliser la bonne syntaxe selon votre hébergeur actuel.

Back to top